129 views
0

获取数据的时候报错:

“TqSdk 使用了 python3 的原生协程和异步通讯库 asyncio,您所使用的 IDE 不支持 asyncio, 请使用 pycharm 或其它支持 asyncio 的 IDE”

代码两种方式都报这个错:

quote = yield from api.get_quote(contract)


quote = await api.get_quote(contract)

请问是什么原因?

Answered question
0

我刚开始学习tqsdk, 实验时当把api放在async里面也遇到这个问题。后来我使用ThreadPoolExecutor避过这个问题。如果使用async的话, 那可以看看这个链接https://www.shinnytech.com/question/12741/, 注意第25行, 我没有试过这个。

Answered question